Activity Log reporting incorrect timestamps

Incident Report for Automox

Resolved

This incident has been resolved.
Posted Dec 04, 2023 - 19:56 UTC

Identified

A fix has been identified and will be issued soon
Posted Dec 04, 2023 - 19:30 UTC

Update

The Activity Log is showing incorrect information, but this appears to only be visually incorrect. Database and API values return correct information. Currently investigating.
Posted Dec 04, 2023 - 19:02 UTC

Investigating

We are currently investigating this issue.
Posted Dec 04, 2023 - 18:57 UTC
This incident affected: Console (web).